New Border Customs Officer Animation not working.

SCS Software ATS and ETS2 editing using ZModeler3 filter. Models, Materials, Animation.

Moderators: Oleg, _RicH_

Post Reply
User avatar
Harald-RS
Beginner
Posts: 228
Joined: Sun Oct 21, 2012 8:08 am
Location: Roggden / Germany

New Border Customs Officer Animation not working.

Post by Harald-RS »

Hi Oleg,

in the Z-Mod the animation runs without problem but in the game the animation does not work and the figures look like this.
animation_dosent_working_in_game_german_border_officers.png
Greetings
Harald
My System: PC Windows 11
User avatar
Oleg
Site Admin
Posts: 12092
Joined: Fri Feb 06, 2004 3:54 am
Contact:

Re: New Border Customs Officer Animation not working.

Post by Oleg »

where are these model files located?
User avatar
Harald-RS
Beginner
Posts: 228
Joined: Sun Oct 21, 2012 8:08 am
Location: Roggden / Germany

Re: New Border Customs Officer Animation not working.

Post by Harald-RS »

Under this path: def/world

def\world\mover.characters.hw.sii

Code: Select all

SiiNunit
{

##############################
# NOTE: To hide OBSOLETE movers from content browser, use mover_name prefix: "__"
# For example:
# 'mover_name: "mover"'  --->  'mover_name: "__mover"'
##############################

mover_model_group : mover.cusoffge_wl
{
	mover_name: "__germany customs officer walk"
	desc_tags[]: man
	desc_tags[]: cusoffger
	anim_tags[]: man
	anim_tags[]: ngn_walk
	pedestrian: true
}

mover_model_group : mover.cusoffge_dog
{
	mover_name: "__germany customs dog handler"
	desc_tags[]: man
	desc_tags[]: cusoffger
	anim_tags[]: man
	anim_tags[]: dog_walk
	pedestrian: true
}
mover_model_group : mover.cusoffge
{
	mover_name: "__germany customs officer idle"
	desc_tags[]: cusoffger
	anim_tags[]: man
	anim_tags[]: idle
	pedestrian: true
}

mover_model_group : mover.cusoffge_sr
{
	mover_name: "__germany customs officer truck search"
	desc_tags[]: man
	desc_tags[]: cusoffger_bb
	anim_tags[]: man
	anim_tags[]: tr_search
	pedestrian: true
}

mover_model_group : mover.cusoffge_tbl
{
	mover_name: "__germany customs officer tablet"
	desc_tags[]: man
	desc_tags[]: cusoffger
	anim_tags[]: man
	anim_tags[]: cus_tablet
	pedestrian: true
}

mover_model_group : mover.cusoffge_sit
{
	mover_name: "__germany customs officer sitting all"
	desc_tags[]: man
	desc_tags[]: cusoffger
	anim_tags[]: man
	anim_tags[]: sitting
	pedestrian: true
}

mover_model_group : mover.cusoffge_mir
{
	mover_name: "__germany customs officer mirror idle"
	desc_tags[]: man
	desc_tags[]: cusoffger
	anim_tags[]: man
	anim_tags[]: cus_mirrid
	pedestrian: true
}
}
mover_desc.hw.sii

Code: Select all

SiiNunit
{
mover_desc : mover_desc.cusoff.ger
{
	model_desc: "/model/pfalz_hw/mover/characters/new_generation/new/models/man/customs_officer/officer_border_01_ger_skn_lod0.pmd"

	variants[]: cenda
	variants[]: nemiro
	variants[]: diego
	variants[]: filip
	variants[]: hynek
	variants[]: johnny
	variants[]: marian

	lods[0]: "/model/pfalz_hw/mover/characters/new_generation/new/models/man/customs_officer/officer_border_01_ger_skn_lod1.pmd"
	lods[1]: "/model/pfalz_hw/mover/characters/new_generation/new/models/man/customs_officer/officer_border_01_ger_skn_lod2.pmd"
	lods[2]: "/model/pfalz_hw/mover/characters/new_generation/new/models/man/customs_officer/officer_border_01_ger_skn_lod3.pmd"
	lods[3]: ""

	lod_distances[0]: 18
	lod_distances[1]: 49
	lod_distances[2]: 128
	lod_distances[3]: 160

	group_tags[]: human
	group_tags[]: man
	group_tags[]: cusoff
	group_tags[]: cusoffger

	area_tags[]: germany	# country

}
}
Greetings
Harald
My System: PC Windows 11
User avatar
Oleg
Site Admin
Posts: 12092
Joined: Fri Feb 06, 2004 3:54 am
Contact:

Re: New Border Customs Officer Animation not working.

Post by Oleg »

no, the model file: pmd,pmg and an associated animation pma files.
User avatar
Harald-RS
Beginner
Posts: 228
Joined: Sun Oct 21, 2012 8:08 am
Location: Roggden / Germany

Re: New Border Customs Officer Animation not working.

Post by Harald-RS »

The animation Files are here:

def/world/mover_anim.sii

Code: Select all

mover_anim : mover_anim.n_cus_search
{
	model_anim: "/model/mover/characters/new_generation/new/animations/customs/customs_truck_search.pma"
	group_tags[]: human
	group_tags[]: man
	group_tags[]: tr_search

	props[]: mover_props.cus_mirror
}

mover_anim : mover_anim.n_cus_tablet
{
	model_anim: "/model/mover/characters/new_generation/new/animations/customs/customs_tablet.pma"
	group_tags[]: human
	group_tags[]: man
	group_tags[]: cus_tablet

	props[]: mover_props.cus_tablet
}

mover_anim : mover_anim.n_cus_mirrid
{
	model_anim: "/model/mover/characters/new_generation/new/animations/customs/idle_with_mirror.pma"
	group_tags[]: human
	group_tags[]: man
	group_tags[]: cus_mirrid

	props[]: mover_props.cus_miridl
}

mover_anim : mover_anim.n_cus_walk
{
	model_anim: "/model/mover/characters/new_generation/new/animations/customs/dog_handler_walk.pma"
	group_tags[]: human
	group_tags[]: man
	group_tags[]: dog_walk

}
Greetings
Harald
My System: PC Windows 11
User avatar
Oleg
Site Admin
Posts: 12092
Joined: Fri Feb 06, 2004 3:54 am
Contact:

Re: New Border Customs Officer Animation not working.

Post by Oleg »

Harald-RS wrote: Tue May 24, 2022 11:39 am Hi Oleg,

in the Z-Mod the animation runs without problem but in the game the animation does not work and the figures look like this.

animation_dosent_working_in_game_german_border_officers.png
may you send me original model files (.pmd + .pmg) and an animation file(s) please? My game being unpacked does not have "customs" folder inside "model\mover\characters\new_generation\animations".


Edit: ouch... found .pma files inside "new" sub folder. But where the associated pmg/pmd models?
User avatar
Oleg
Site Admin
Posts: 12092
Joined: Fri Feb 06, 2004 3:54 am
Contact:

Re: New Border Customs Officer Animation not working.

Post by Oleg »

Ok. There was an update in animation files import/export. They are exported in version 5, while these character animations are version 4. Is your game updated to latest version? the recent game update uses PMA files version 5.
User avatar
Harald-RS
Beginner
Posts: 228
Joined: Sun Oct 21, 2012 8:08 am
Location: Roggden / Germany

Re: New Border Customs Officer Animation not working.

Post by Harald-RS »

Oleg, I don't know that, but the PMAs are from SCS Stand 1.44.

And I took the Russian border police officer as a basis.

Just give him a new skin for the safety waistcoat.

And as I said, in the Z-Mod he moves with the SCS animation without problems, but not in the game and he is not recognised in the map editor. But in the game it is then displayed in a strange white.
Greetings
Harald
My System: PC Windows 11
User avatar
Oleg
Site Admin
Posts: 12092
Joined: Fri Feb 06, 2004 3:54 am
Contact:

Re: New Border Customs Officer Animation not working.

Post by Oleg »

do you edit .pmd/.pmg model only? or you import/export .pma file too?
User avatar
Harald-RS
Beginner
Posts: 228
Joined: Sun Oct 21, 2012 8:08 am
Location: Roggden / Germany

Re: New Border Customs Officer Animation not working.

Post by Harald-RS »

Hi Oleg,

only edit pmd & pmg

----- Edit -----

I've got it working now.

I have resaved all the animation files.
Greetings
Harald
My System: PC Windows 11
User avatar
Oleg
Site Admin
Posts: 12092
Joined: Fri Feb 06, 2004 3:54 am
Contact:

Re: New Border Customs Officer Animation not working.

Post by Oleg »

Animation files contain a hash value that is (most likely) evaluated on hierarchy of model file. Unfortunately, I don't know how they calculate it, so ZModeler exports animations with no hash value. The game allows animation to be applied to a model if hash matches (assuming the animation was created for the specified geometry model/scene), or when no hash is inside .pma file (ZModeler's re-export scenario).

I either need to know the hash is evaluated or re-saving all .pma files is the only option we have for animations now. :(
User avatar
Harald-RS
Beginner
Posts: 228
Joined: Sun Oct 21, 2012 8:08 am
Location: Roggden / Germany

Re: New Border Customs Officer Animation not working.

Post by Harald-RS »

Yes, and then the figures from SCS no longer work, which is a pity. That's why you have to create a separate folder for the animation you create yourself and also new sii files for the animation and the 3D model.
Greetings
Harald
My System: PC Windows 11
User avatar
Oleg
Site Admin
Posts: 12092
Joined: Fri Feb 06, 2004 3:54 am
Contact:

Re: New Border Customs Officer Animation not working.

Post by Oleg »

does vehicle's interior animation suffer the same issue? I mean, if you import anim.pmd model and export with no changes - all native animations (pma) are no longer working?
Fazer001
Posts: 38
Joined: Sun Feb 26, 2017 5:49 am

Re: New Border Customs Officer Animation not working.

Post by Fazer001 »

Oleg wrote: Sun May 29, 2022 10:28 am does vehicle's interior animation suffer the same issue? I mean, if you import anim.pmd model and export with no changes - all native animations (pma) are no longer working?
The new anim update Oleg works fine.

I don't know what he do.... it looks like something's shifted
User avatar
Harald-RS
Beginner
Posts: 228
Joined: Sun Oct 21, 2012 8:08 am
Location: Roggden / Germany

Re: New Border Customs Officer Animation not working.

Post by Harald-RS »

Hello Oleg, I have not tried this with the trucks.
Greetings
Harald
My System: PC Windows 11
Post Reply