[SOLVED] Collision problem

GTA:V Modding with ZModeler3 discussion.

Moderator: madga182

User avatar
Oleg
Site Admin
Posts: 11180
Joined: Fri Feb 06, 2004 3:54 am
Contact:

Re: Collision problem

Post by Oleg »

the fix will be available in next update. i'll check my todo list to find out whether there are some other pending issues I could get fixed in a day to include in release.

eta: in 18 hours
User avatar
Oleg
Site Admin
Posts: 11180
Joined: Fri Feb 06, 2004 3:54 am
Contact:

Re: Collision problem

Post by Oleg »

The fix is available in updated version. ZModeler build is updated too (1179), so if you have a license issue, configure online validation to get your license revalidated properly.

Also includes current implementation of ped cloth-simulation meshes too. will make a dedicated post on this subject few later, as some cloth-specific bugs are still there (and not yet possible to resolve in reasonable time frame).
User avatar
FoxtrotDelta
Posts: 20
Joined: Mon Aug 07, 2017 4:30 am
Location: China-Pakistan
Contact:

Re: Collision problem

Post by FoxtrotDelta »

umm. why is everyone mentioning planes (Aircraft) did i miss something? i haven't had trouble with aircraft collisions with x64 version of zmodeler 3 yet.

please do advise if i am missing something. in my opnion the boat collisions are the only ones having this issue?



oh yea i did just get an update. will test tugboat :))
Im no Expert i Learn New Stuff Everyday
cegta
Posts: 13
Joined: Tue Feb 20, 2018 9:47 am
Contact:

Re: Collision problem

Post by cegta »

Oleg THANK MUCH THANK !
pnwparksfan
Posts: 47
Joined: Wed Feb 14, 2018 7:24 pm

Re: Collision problem

Post by pnwparksfan »

Unfortunately I am still having the same problem in the latest Zmodeler3 update from today. It looks pretty much exactly the same as before. Tested with the default TUG model and with a custom model; both have the issue. Tried with both 32-bit and 64-bit zmod, both updated to latest version.
pnwparksfan
Posts: 47
Joined: Wed Feb 14, 2018 7:24 pm

Re: Collision problem

Post by pnwparksfan »

FoxtrotDelta wrote:umm. why is everyone mentioning planes (Aircraft) did i miss something? i haven't had trouble with aircraft collisions with x64 version of zmodeler 3 yet.

please do advise if i am missing something. in my opnion the boat collisions are the only ones having this issue?



oh yea i did just get an update. will test tugboat :))

This does happen on large planes with doubled collisions, like the Titan. See this video for example, you can see the camera clips through the model where it shouldn't, and the player can walk through the side of the plane.

-amaURRQ36E
TomcattersVF31
Beginner
Posts: 101
Joined: Fri May 18, 2012 10:13 pm

Re: Collision problem

Post by TomcattersVF31 »

It's pretty much any vehicle that uses the double COL Format with a deformable and non-deformable mesh. So technically it could happen on enterable trucks or cars, helicopters, Trains, etc as well.
User avatar
Oleg
Site Admin
Posts: 11180
Joined: Fri Feb 06, 2004 3:54 am
Contact:

Re: Collision problem

Post by Oleg »

pnwparksfan wrote: This does happen on large planes with doubled collisions, like the Titan. See this video for example, you can see the camera clips through the model where it shouldn't, and the player can walk through the side of the plane.
does this happen after recent update?
pnwparksfan
Posts: 47
Joined: Wed Feb 14, 2018 7:24 pm

Re: Collision problem

Post by pnwparksfan »

Yes, this was tested after installing the new update. I installed the update, restarted zmod, and imported/exported the titan and the tug, each without any changes at all. Both have the issue still. Tried with both 32-bit and 64-bit zmod 3.2.0.
User avatar
Oleg
Site Admin
Posts: 11180
Joined: Fri Feb 06, 2004 3:54 am
Contact:

Re: Collision problem

Post by Oleg »

no, I can't reproduce it. here's an imported (deleted two polygons on a tail) and exported titan:
titan_01.jpg
player does not fall through the ground, can not walk out through walls, as well as camera does not fly away and properly clipped/constrained by interior of titan's cargo load area:
titan_02.jpg
don't mind a spike on a head, it's just to be sure I see a modded player model, pretty alike to removed polygon on a tail of this plane.
TomcattersVF31
Beginner
Posts: 101
Joined: Fri May 18, 2012 10:13 pm

Re: Collision problem

Post by TomcattersVF31 »

I still have problems as well, so far only tested boats though.

Can it be, that you forgot to include something in the update? In the affected file dropdown I couldn't spot anything GTA/RAGE related.
User avatar
Oleg
Site Admin
Posts: 11180
Joined: Fri Feb 06, 2004 3:54 am
Contact:

Re: Collision problem

Post by Oleg »

ohh.., sorry, quite likely I did, GtaRage.zmf shows Feburary 10th in updates database. will upload an update shortly.
TomcattersVF31
Beginner
Posts: 101
Joined: Fri May 18, 2012 10:13 pm

Re: Collision problem

Post by TomcattersVF31 »

No problem, I was just wondering if that might have been the issue :D
TomcattersVF31
Beginner
Posts: 101
Joined: Fri May 18, 2012 10:13 pm

Re: Collision problem

Post by TomcattersVF31 »

Can confirm it works now. Thanks very much!
User avatar
FoxtrotDelta
Posts: 20
Joined: Mon Aug 07, 2017 4:30 am
Location: China-Pakistan
Contact:

Re: [SOLVED] Collision problem

Post by FoxtrotDelta »

Thanks alot for helping.
Im no Expert i Learn New Stuff Everyday
BeunhaasNL
Posts: 1
Joined: Tue Feb 19, 2019 10:52 pm

Re: [SOLVED] Collision problem

Post by BeunhaasNL »

am too having difficulties with boat collisions...

i have this weird glitch, where my collision is positioned above the model mesh....


https://www.youtube.com/watch?v=WwvRS5n ... e=youtu.be
User avatar
Oleg
Site Admin
Posts: 11180
Joined: Fri Feb 06, 2004 3:54 am
Contact:

Re: [SOLVED] Collision problem

Post by Oleg »

quite likely this is related to location of local axes on "chassis" and "chassis [COL]" object(s). both should be at 0,0,0 point probably. also, ungroup collisions (if you have them grouped) and reset axes on components; then group again.

Also, quite helpful to import your model back into ZModeler and check whether everything related to collision is retained in place and all components are located properly.
User avatar
tall70
Amateur
Posts: 675
Joined: Tue Aug 11, 2015 3:13 pm

Re: [SOLVED] Collision problem

Post by tall70 »

Also XML settings can put boat below the level, I believe it's a box values and submerge level too... driving the boat on a land will tell you if your Collision is offset or it's settings
gtamodder8
Posts: 15
Joined: Fri Jun 15, 2018 3:10 am

Re: [SOLVED] Collision problem

Post by gtamodder8 »

If you have the character falling through collision issue, just untick the deformable option of the COL object and export. I had this issue when i renamed a spoiler part of a car to "wing_rf" so that it gets detached from the body when collided heavily, i removed that option and it works but the object after detaching from the body disappears and doesn't fall on the ground like doors and bonnets..
apbnetwork
Posts: 17
Joined: Mon Oct 08, 2018 9:37 pm

Re: [SOLVED] Collision problem

Post by apbnetwork »

Hi,

I just found out that this specific problem is still present when editing the model of the Cargo Plane (cargoplane.yft and cargoplane_hi.yft). Oleg, would you mind looking into this?
In order to reproduce the issue, all you need to do is simply import and export the model and then spawn it into the game. Then, try running down from the top of the plane towards an edge of the wing. Eventually, you'll just fall through the collision of the wing. Happens on both sides, and I have no idea how to prevent that from happening.
Post Reply