Taxi Lights

GTA:V Modding with ZModeler3 discussion.

Moderator: madga182

Post Reply
snit
Posts: 8
Joined: Fri Dec 21, 2012 2:44 am

Taxi Lights

Post by snit »

Hey all

So I start working on a taxi with a taxi sign on the roof, I've been attempting to get the taxi sign to light up but it, unfortunately, has been working.

The External state ID for the taxi lights used by default GTA cars is 18. I've applied this to my own in polygon mode with the correct light-emissive shader applied to the material, however, in-game the sign doesn't light up at all, and using a trainer to turn the light on/off has no effect.

I've attached a screenshot showing the ID correctly applied.

I've also tried straight importing and then exporting default GTA taxi, doing so causes the taxi sign light to also become non-functional.

If any knows the cause/fix for this, it would be great. It could also be a bug.
Attachments
taxi.png
snit
Posts: 8
Joined: Fri Dec 21, 2012 2:44 am

Re: Taxi Lights

Post by snit »

Anyone have any info on this?
User avatar
Oleg
Site Admin
Posts: 11181
Joined: Fri Feb 06, 2004 3:54 am
Contact:

Re: Taxi Lights

Post by Oleg »

haven't tested this myself on original vehicle. Have you tried to re-import a modded file back into ZModeler to see whether ID is retained or not?
snit
Posts: 8
Joined: Fri Dec 21, 2012 2:44 am

Re: Taxi Lights

Post by snit »

Oleg wrote: Wed Apr 14, 2021 12:12 pm haven't tested this myself on original vehicle. Have you tried to re-import a modded file back into ZModeler to see whether ID is retained or not?
Just got around to trying this. When exporting and reimporting the correct ID is retained.
User avatar
Deadspin
Beginner
Posts: 105
Joined: Sun Sep 10, 2017 1:34 pm
Location: North Carolina

Re: Taxi Lights

Post by Deadspin »

snit wrote: Sat Mar 20, 2021 3:31 pm The External state ID for the taxi lights used by default GTA cars is 18.
Use 0 (zero).
[Lore and 3rd Party Emergency Vehicles | Custom Ped/EUP]
Post Reply