Trailer Model Disappearing In Game

SCS Software ATS and ETS2 editing using ZModeler3 filter. Models, Materials, Animation.

Moderators: Oleg, _RicH_

Post Reply
18woshfan
Posts: 1
Joined: Sat Nov 15, 2008 9:12 pm

Trailer Model Disappearing In Game

Post by 18woshfan »

Im not really sure what to call this but im having issues where my trailer models will disappear in game on certain angles.

As you can see from the attached pictures.

Not sure if its a mat issue or what but i tried searching around but to no avail.

https://imgur.com/a/b8R9JsN

https://imgur.com/a/MjcJuP1

Any help much appreciated.
User avatar
Oleg
Site Admin
Posts: 11300
Joined: Fri Feb 06, 2004 3:54 am
Contact:

Re: Trailer Model Disappearing In Game

Post by Oleg »

sorry I can't spot a problem on these screenshots. is it possible to record a short video showing the moment of model disappearing?

In general, each model has a bounding box information and game is expected to use this information to determine whether the model is visible or not. I doubt something could be messed up in scene here. The only thing I could think of is a non-uniform scale on your model (each model and dummy node is generally expected to have scale of 1.0 on all axes). If you rescaled a model at some stage, the scale on axes could be altered (so the model is shown in proper size). The bounding volume does not respect model scale and could tell the game incorrect dimensions of geometry model.

Also, it is advised to reset object axes to zero point (reset to world) on every part where it's possible (of cause you should not reset axes on dummy nodes that are locators or place-holders for game-specific stuff).
Post Reply