"Seek failed" on opening .z3d

Troubleshooting gudes, solutions and other ZModeler3-related discussion

Moderators: Oleg, madga182

Post Reply
Posts: 7
Joined: Wed Jun 05, 2019 11:07 am

"Seek failed" on opening .z3d

Post by TacticalDonut »

No idea what's going on here. Spent a few hours on a car, saved the file, turned off my computer, and wanted to come back to it a couple of hours later.

Tried to start zmod, but it apparently destroyed itself and decided to not find the hardware profile for my GPU, so I had to delete the entire zmodeler folder. Redownloaded and tried to open the vehicle file, and then received an error stating "Seek failed on [path to file]". The message box was also filled with lines stating "Texture '(null)' was not found."

Really don't want to have to redo this stupid car, given that literally the only thing I did after saving the file and verifying that it would open again was restart my computer. Anything I can do otherwise?
User avatar
Site Admin
Posts: 11572
Joined: Fri Feb 06, 2004 3:54 am

Re: "Seek failed" on opening .z3d

Post by Oleg »

It looks like ZModeler shutdown was interrupt and it could corrupt file it was saving (as well as configuration profile too). Check the autosave files in ZModeler folder, may be they contain some stage of your scene saved.

The "seek failed" is most likely the interrupt (incomplete) file.

It is strongly advised to save scene before you close ZModeler. So, explicitly pick File\Save. Once scene is saved, you can close ZModeler. If you use Close -> "Do you want to save?" -> "Yes" chain, it is likely the save could take a long and OS Windows will terminate ZModeler process somewhere in between of saving.

"Texture (null) not found" is a hint too. The file got corrupt at a point of saving of textures. May be you had a lot of textures loaded and ZModeler took a long time while saving all your textures into a .z3d file. You can disable texture saving option in "Settings->General->Z3d Open & Save" -> "Store textures".

and a side note: when you use File\Merge quite a lot, you are likely to get a lot of textures in Textures browser, since some identical textures could get duplicates. ZModeler does not compare textures themselves and loads all required textures from a merged file (for example, if you already have texture with the same name, it could happen you have a different texture under the same name in a merged file, so ZModeler loads all textures as-is).
Post Reply