Zmodeler crashes when merging

GTA:V Modding with ZModeler3 discussion.
Post Reply
Trippin
Posts: 17
Joined: Wed Jun 21, 2023 1:01 am

Zmodeler crashes when merging

Post by Trippin »

It's me...again..with yet another problem.

Whenever I attempt to merge a car with a lightbar, my zmodeler just crashes. No errors etc.

It was working previously however all of a sudden stopped and began crashing. I have re-done my steps up to when it was working, but when I get to merging, it just closes and that's it.
User avatar
Oleg
Site Admin
Posts: 14339
Joined: Fri Feb 06, 2004 3:54 am
Contact:

Re: Zmodeler crashes when merging

Post by Oleg »

install ZModeler in a different folder, reboot your computer and try again.
Also, there were reports that ZModeler can crash randomly when it runs on laptop devices with on-CPU rendering device selected (like Intel Graphics device). If you can change ZModeler to run on a different video hardware, it have to be set (on Settings->Rendering->Device) page.
If still no luck, you can send me a download link to your .z3d scene and your .z3d file that causes crash on merge. May be something is wrong with the file itself.

Also, can you File\Open this file (the one you try to merge)? Does it load fine this way?
GreaseMonkey
Posts: 2
Joined: Tue Jul 02, 2024 5:39 pm

Re: Zmodeler crashes when merging

Post by GreaseMonkey »

I have changed the graphics gpu. Because I am running it on a laptop as well. And it wont change the setting I want it to be. When I do change the setting while Zmod is still running. It still crashes to desktop. No error codes or anything. And with what I am trying to do is merge in a set of dials for a vehicle. Well merge in anything. Like wheels or something else. If it's not converted it is fine and merges. But if the file has bin converted on the other hand. It says 100% at the bottom and my mouse has the loading wheel next to it. it crashes to desktop.
User avatar
Oleg
Site Admin
Posts: 14339
Joined: Fri Feb 06, 2004 3:54 am
Contact:

Re: Zmodeler crashes when merging

Post by Oleg »

there's something wrong with the .z3d file itself. I advise to open the scene (File\Open) and remove all unnecessary data from this file. If you need dials only, delete everything else.

Also, if you use file\merge quite a lot, some trash is accumulated from .z3d files you load. In particular, a set of paths to textures (where to search for textures) is keep increasing and might contain invalid/incorrect paths. Check the Settings\Services\Textures for bad paths and remove unnecessary. This set is saved in a .z3d file too, so check what's in a problematic .z3d file and clear paths set in this file too.

Once again, if you can safely File\Open this .z3d file, then the file should be OK for merge.
Post Reply