Prelight Problem

ZModeler2-related discussion. General questions, howto, etc.

Moderators: Oleg, _RicH_

Prelight Problem

Postby Automan » Tue Jan 03, 2017 2:23 am

As I explained to a user the Prelight, I realized that does not work as I remembered:
I do not understand the problem, I have always done so... :|


I have solved, somehow...

(Note: ZM2 does not give all the necessary data for map objects.
At the end of prelight must attach the object map to an object map of SA,
to which is assigned the default material, then it can be easily erased).

To run prelight use the latest version, ZM2 226, 993 Build.
This version works in reverse of the above,
that makes dark the object; so if you already black, nothing happens...
Go to "Options/Settings", and change "Ambient Light" from black to white:

A map object is different from the other 3D, weapons, vehicles and peds, as regards the management of the vertices:

Now the object is full of light:
The prelight making projection from the "Perspective" or "User" view, selecting the leaders concerned.
I do not recommend performing prelight of all vertices, because those behind did not receive light.

To perform the cube prelight of all vertices:
Press left clik mouse to the desired level of light:

Mapping objects have 2 prelight, for the day and for the night.
To handle the light at night, it click "Swap colors":
Let's change the light from tentende to yellow to tending to blue, for external objects:

To sum it all.
ZM2 could reverse the day/night cycle, check in game this.
User avatar
Posts: 113
Joined: Tue Mar 06, 2007 1:27 pm
Location: Italy

Return to ZModeler2 General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest