ZModeler v2.2.6 (08 November 2011)

ZModeler2-related discussion. General questions, howto, etc.

Moderators: Oleg, _RicH_

Re: ZModeler v2.2.6 (08 November 2011)

Postby Oleg » Wed Jun 18, 2014 9:31 am

Install DirectX 9.0c June 2010 Redistributive.

The link is in a first topic.
User avatar
Oleg
Site Admin
 
Posts: 7390
Joined: Fri Feb 06, 2004 3:54 am

Re: ZModeler v2.2.6 (08 November 2011)

Postby Desman » Mon Jul 28, 2014 4:45 pm

Have some trouble again,
the ZModeler stopped responding and crashed meanwhile it was exporting the wft file.
anyway to know to the fix that?
Desman
 
Posts: 4
Joined: Tue Jan 01, 2013 11:46 pm

Re: ZModeler v2.2.6 (08 November 2011)

Postby Desman » Mon Aug 11, 2014 4:54 pm

I know you are not giving much attention to zm2 now, but since you made the software and you ARE the expert on this, which I would likely to be having no idea what causing that to happen, mane maybe you can help me with giving me some ideas what will cause that export crash, that would so helpful to me.
Desman
 
Posts: 4
Joined: Tue Jan 01, 2013 11:46 pm

Re: ZModeler v2.2.6 (08 November 2011)

Postby Oleg » Wed Aug 13, 2014 12:31 am

I can recommend to set up one material exactly the same was as original material is loaded, then assign it to all objects in your scene. Then export. If not crash occur, then materials are the cause. Otherwise, your scene is a problem.

first of all, check the hierarchy, there could be duplicate names which are prohibited. remove all COL objects and replace them with COL objects from any original vehicle. COLs are very specific and you should try your mod with original, good-working COLs at first.

Poly count could give some problems too. The entire model is merged into single geometry on export, so if you have very detailed parts, all in one they could produce an excessive count of vertices/polygons on a model.
User avatar
Oleg
Site Admin
 
Posts: 7390
Joined: Fri Feb 06, 2004 3:54 am

Re: ZModeler v2.2.6 (08 November 2011)

Postby Desman » Fri Aug 15, 2014 12:45 am

I tried the first way, not exactly the way idk :P, but to have the car applying to every single material, tested out both of the carbon materials, so idk if it was the texture, and thinking if the way to fix is to use another texture or not
Image

if there is any duplicate names found it will show up in the messaging bar right? The mesh is kinda very detailed and with not IV original COLs, but tested them b4 and quite sure they are fine.
Desman
 
Posts: 4
Joined: Tue Jan 01, 2013 11:46 pm

Zmod Crashes When I Import DFF's

Postby gogetr1 » Fri Feb 13, 2015 5:13 am

Whenever I try to import any dff's or open certain z3d files Zmod will crash. From the looks of things I have all of the components installed that I need. Maybe I'm missing one? What might the problem be. all 2005 C++, DirectX all installed.
User avatar
gogetr1
 
Posts: 14
Joined: Wed Oct 28, 2009 2:13 pm

Re: ZModeler v2.2.6 (08 November 2011)

Postby Oleg » Fri Feb 13, 2015 8:38 am

do you have materials editor and textures browser? if not, DirectX 9.0c June 2010 installation is a must.
User avatar
Oleg
Site Admin
 
Posts: 7390
Joined: Fri Feb 06, 2004 3:54 am

Re: ZModeler v2.2.6 (08 November 2011)

Postby gogetr1 » Fri Feb 13, 2015 2:04 pm

Ok, I've downloaded and extracted the DirectX redistributable and it is full of numerous files :shock: which one am I looking to install :mrgreen:
*Update* I've double checked since my last post and it looks like my comp has DirectX 11 permanently installed, DirectX 9 only seems to be installing and because of the way it is installed I can't uninstall it. Is this good or bad?
User avatar
gogetr1
 
Posts: 14
Joined: Wed Oct 28, 2009 2:13 pm

Re: ZModeler v2.2.6 (08 November 2011)

Postby Oleg » Sat Feb 14, 2015 12:39 am

you should run dxsetup.exe

having directx11 installed is not related to zmodeler, neither related to directx9 installation. By installing dx9 you will equip your system with additional libraries that Zmodeler requires.
User avatar
Oleg
Site Admin
 
Posts: 7390
Joined: Fri Feb 06, 2004 3:54 am

Re: ZModeler v2.2.6 (08 November 2011)

Postby gogetr1 » Sat Feb 14, 2015 1:28 am

Oleg wrote:you should run dxsetup.exe

having directx11 installed is not related to zmodeler, neither related to directx9 installation. By installing dx9 you will equip your system with additional libraries that Zmodeler requires.


Better.
User avatar
gogetr1
 
Posts: 14
Joined: Wed Oct 28, 2009 2:13 pm

Error When Zmod is Exited

Postby gogetr1 » Mon May 04, 2015 1:54 pm

This is a new problem that I have, excuse the double bump. When I close Zmod2 on windows vista I get the 'Windows has stopped working' message, usually after I've done some mapping but not any other time and no solutions ever come out from the 'windows is checking for a solution' feature that comes up after the crash. I'm pretty sure that it's screwing with my models coming out the way that I want them to, like chrome rims are reflecting ENV maps horribly or chrome isn't stable, it's bright then it dims as the wheel turns. I think that there is another plug-in missing, can you guess what it is from the description that I gave?
User avatar
gogetr1
 
Posts: 14
Joined: Wed Oct 28, 2009 2:13 pm

Re: ZModeler v2.2.6 (08 November 2011)

Postby Oleg » Mon May 04, 2015 9:14 pm

AppCrash on close is not related to any bugs of your mods. It is caused by inaccurate memory release in some modules. So, even if you close program and use "Save changes" on close, it will save correct .z3d file too.
User avatar
Oleg
Site Admin
 
Posts: 7390
Joined: Fri Feb 06, 2004 3:54 am

Re: ZModeler v2.2.6 (08 November 2011)

Postby gogetr1 » Mon May 04, 2015 11:06 pm

Ok. The crash itself is still annoying though, can you say what might be causing it?
User avatar
gogetr1
 
Posts: 14
Joined: Wed Oct 28, 2009 2:13 pm

Re: ZModeler v2.2.6 (08 November 2011)

Postby Oleg » Tue May 05, 2015 12:14 am

I don't remember. I had the same years ago in zmod3 and fixed it if i'm not mistaken. there were several similar issues causing appcrash on exit, to the moment zmod3 closes with no crash.
User avatar
Oleg
Site Admin
 
Posts: 7390
Joined: Fri Feb 06, 2004 3:54 am

Previous

Return to ZModeler2 General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron