Page 1 of 1

Scene empty after import

PostPosted: Sun Jul 09, 2017 4:16 am
by Headshots_Ops
Hello

I'm trying to import some map files into Zmodeler3.
Almost all models work fine but some of them appear as empty after import

Example: Seagift and Kingstone (located in the city folder)

I used the same procedure as described in the guide, it works for almost every model except most interiors and kingston

At first Zmodeler looks like its loading, but after it's done, the scene is just empty and no objects have appeared in the list either.
This is what I get after importation of kingston
Image

Apart from that, im getting some regular missing texture errors, but that shouldn't be the problem as far as I know.

Thanks for the help.

Re: Scene empty after import

PostPosted: Sun Jul 09, 2017 6:55 am
by Oleg
importer was not tested on scene/map objects. It might abandon import on unexpected data. Also, not sure on "Unknown shader adaptation" - it might stop import too, but very unlikely it is the cause.

Re: Scene empty after import

PostPosted: Sun Jul 09, 2017 9:45 am
by Headshots_Ops
Oleg wrote:importer was not tested on scene/map objects. It might abandon import on unexpected data. Also, not sure on "Unknown shader adaptation" - it might stop import too, but very unlikely it is the cause.


Ah I see.
The unknown shader adaption apeared all the time whilst importing map or scene models but that didn't cause any problems on the succesfully imported ones.

I've been messing a bit with the FrameResource_0.bin in a hex editor and it seems that the marked bit of data represents the amount of scene groups.
Image
changing this to any number would upon importation actually create some object hierarchy but its a bit messed up and still no objects in the scene.
If I delete a IndexBufferpool and VertexBufferpool file, Zmodeler gives an error after importation that it can not find e.g "scene.kingstn36.random"

So it certainly is being read but for some reason something must cancel it after i guess, like you said.

Is there like a log file that would maybe indicate what has gone wrong after importation? The error report within the program doesn't give any errors except for the usual shader and texture errors.

Thank you

Re: Scene empty after import

PostPosted: Sun Jul 09, 2017 9:14 pm
by Oleg
send me an unpacked folder with files. the detailed import log is created by debug build of zmodeler and import/export filters.

Re: Scene empty after import

PostPosted: Tue Jul 11, 2017 10:35 am
by Headshots_Ops
Oleg wrote:send me an unpacked folder with files. the detailed import log is created by debug build of zmodeler and import/export filters.


Here' s a direct link:
http://download1029.mediafire.com/t5l1f ... gstone.rar

Thanks for looking into it.

Re: Scene empty after import

PostPosted: Wed Jul 12, 2017 6:21 am
by Oleg
it will be importable in next update. my current zmod version 3.1.5, I can't upload fix for version 3.1.4.

Re: Scene empty after import

PostPosted: Fri Jul 14, 2017 1:50 am
by Headshots_Ops
Awesome! thanks alot

Re: Scene empty after import

PostPosted: Mon Jul 24, 2017 2:15 am
by Headshots_Ops
Oleg wrote:it will be importable in next update. my current zmod version 3.1.5, I can't upload fix for version 3.1.4.


Hi, first of all thank you for fixing that, it works now. However some sds's are still suffering from the same issue.

Since the update i've been able to import some models that weren't importable before, but alot still remain with the same issue.
I've included 3 files that import but give an empty scene.

One is seagift, the other gasstation and i've also included the yacht house from the joe's adventures dlc which seems to suffer a different issue upon import.
The scene is still empty but an error comes up in the log saying "Can not locate material 6c0f6c9d57d922b7. Ensure correct material libraries were specified." (this error only applies to some dlc sds's)

http://download1199.mediafire.com/rn5nl ... cyacht.rar
http://download1935.mediafire.com/ryesx ... eagift.rar
http://download1656.mediafire.com/3n4g9 ... y9/gas.rar

I hope this is fixable just like the previous issue

Thanks for your time.

Re: Scene empty after import

PostPosted: Mon Aug 07, 2017 1:47 am
by Headshots_Ops
@Oleg

Sorry if this is not really something you want to spent time on. Just asking if it can be looked into or not, it's basically the same symptoms like before but mostly within the shops sds's. Your previous fix has allowed alot more to be imported, so it would be awesome if those files I sent you can be imported aswell.
But I understand that this might not really be something you want to spent time on.

Looking forward to your answer,

Thanks

Re: Scene empty after import

PostPosted: Tue Aug 08, 2017 4:44 am
by Oleg
this will require more research in depth.. in next update probably.

Re: Scene empty after import

PostPosted: Tue Aug 08, 2017 9:52 am
by Headshots_Ops
Oleg wrote:this will require more research in depth.. in next update probably.


Okay that sounds great.

Just to make sure, the file you downloaded (dlcyacht) has probably a different issue then the two other files i linked.

It seems that the 2 other ones have the exact same symptoms on import like before (the issue you fixed). The dlcyacht.sds that you downloaded looks like it has a more difficult issue. The other two files might be easier to fix maybe I dont know.

I assume your time to work on issues like these is limited. So if you don't have time to fix both, I think fixing the gas/seagift.sds problem is more worth it.

To put things simpler:

Before, kingston.sds showed nothing when imported. You fixed that issue, along with it some files suffering the same issue got fixed aswell.
But files like gas.sds and seagift.sds still import empty.
There is another problem which only occurs on dlc sds's, I care more to have the other ones (like gas and seagift) fixed, but ofcourse if you find time for it it would be cool aswell.

Here's the link to gas and seagift

http://download1935.mediafire.com/ryesx ... eagift.rar
http://download1656.mediafire.com/3n4g9 ... y9/gas.rar


I hope I'm not confusing you too much :p

Thanks