[Solved]Ped_emissive Material not working.

GTA:V Modding with ZModeler3 discussion.

Moderator: madga182

[Solved]Ped_emissive Material not working.

Postby Yoha » Thu Nov 02, 2017 10:11 pm

The work result show, :D Enjoy~~
Hatsune Miku 1st Live show in Los santos.


Hi Oleg and everyone,

Does anyone know why Ped_emissive Material not working?
I set this material to my character, but the model doesn't glow in game.

I checked original game model: which is the one like tron character.
I used it's emissive material, but still not glow.

Then I found a mod call tron on 5mods, his character can glow.
I imported his model, and use his emissive material, then my model can glow.
But I just use the material on my caharacter's leg.
Later, I use this same material to my character's skirt and body.
Pity, these parts still not glow.

very strange.

I used same setting as Tron's emissive material, like diffuse and specular color, and user define data, etc.
I even checked the vertex color of two models, Tron and mine.
Both are same color in primary (orange) and secondary (black) channel.

Have no clue on this ped_emissive material...

screenshots:
QQ图片20171103160853.png

QQ图片20171103160900.png

QQ图片20171103160906.png

QQ图片20171103160914.png
Last edited by Yoha on Mon Nov 06, 2017 5:15 pm, edited 4 times in total.
User avatar
Yoha
 
Posts: 56
Joined: Fri Jun 05, 2015 4:57 pm
Location: China

Re: Ped_emissive Material not working.

Postby Oleg » Thu Nov 02, 2017 10:23 pm

have you inspected user-defined options on materials?
User avatar
Oleg
Site Admin
 
Posts: 7959
Joined: Fri Feb 06, 2004 3:54 am

Re: Ped_emissive Material not working.

Postby Yoha » Fri Nov 03, 2017 4:44 am

Oleg wrote:have you inspected user-defined options on materials?


Thanks for reply, Oleg.

Yes, I did.
I checked everything I can thought.

Here I show you the two materials:
bbb-04.jpg

bbb-05.jpg

bbb-06.jpg
User avatar
Yoha
 
Posts: 56
Joined: Fri Jun 05, 2015 4:57 pm
Location: China

Re: Ped_emissive Material not working.

Postby Oleg » Fri Nov 03, 2017 12:32 pm

inspect per=vertex colors and per-vertex alpha (primary and secondary) using Surface\Paint\Color\Pick from vertex. it is quite possible emissive strength is affected by per-vertex data.

additionally, inspect trons textures, may be alpha channel relates to this issue too.
Also, when you pick tron model for import, do you see any thumbnail image or text comment - was it created by ZModeler or by GIMS?
User avatar
Oleg
Site Admin
 
Posts: 7959
Joined: Fri Feb 06, 2004 3:54 am

Re: Ped_emissive Material not working.

Postby Yoha » Sat Nov 04, 2017 3:52 am

Oleg wrote:inspect per=vertex colors and per-vertex alpha (primary and secondary) using Surface\Paint\Color\Pick from vertex. it is quite possible emissive strength is affected by per-vertex data.

additionally, inspect trons textures, may be alpha channel relates to this issue too.
Also, when you pick tron model for import, do you see any thumbnail image or text comment - was it created by ZModeler or by GIMS?


Thanks, oleg.
I will check it now.
User avatar
Yoha
 
Posts: 56
Joined: Fri Jun 05, 2015 4:57 pm
Location: China

Re: Ped_emissive Material not working.

Postby Yoha » Sat Nov 04, 2017 7:48 pm

Oleg wrote:inspect per=vertex colors and per-vertex alpha (primary and secondary) using Surface\Paint\Color\Pick from vertex. it is quite possible emissive strength is affected by per-vertex data.

additionally, inspect trons textures, may be alpha channel relates to this issue too.
Also, when you pick tron model for import, do you see any thumbnail image or text comment - was it created by ZModeler or by GIMS?

:D :D :D

It works!

I checked vertex color of tron, and found a different color.

Now, I set B channel of primary color to white color, then the it glow! :D
Before, my B channel is black color, that's why it didn't glow.

QQ图片20171105134526.png

QQ图片20171105134532.png
QQ图片20171105134532.png (178.03 KiB) Viewed 202 times
User avatar
Yoha
 
Posts: 56
Joined: Fri Jun 05, 2015 4:57 pm
Location: China


Return to Grand Theft Auto V

Who is online

Users browsing this forum: No registered users and 3 guests