Page 1 of 1

wheel collision clipping sideways

PostPosted: Thu Nov 02, 2017 12:16 pm
by tall70
I'm not sure what i don't remember, if anybody knows...I did try to reset it to parent...I made it even wider then mesh it self and it still seems to remain original width and clips into objects and vehicles. Directions have 2 lines dedicated to wheel col. not seeing anything about it.

https://drive.google.com/open?id=1bmzXQtdG5e3anNQ9hDAHVwdcYEtZXhpg

https://drive.google.com/open?id=10HDDuPha2J8agDzE7CzgtGWzsVrvD4Wb

Also to Oleg
- 2nd image shows little bug in hierarchy, if i reopen save file which has selected objects, boxes have no solid blue square in them until i deselect and re-select them
- also any ZM save i open, after any action(s), if i back up one more before first action, instead of ignoring it, it crashes with "zmodeler stopped working message"
non of these bother me, i just avoid those, it's 4 your information

Re: wheel collision clipping sideways

PostPosted: Thu Nov 02, 2017 9:09 pm
by Oleg
can you provide images and more details please?

Re: wheel collision clipping sideways

PostPosted: Thu Nov 02, 2017 11:08 pm
by tall70
pfff google...previews expired, links now

Re: wheel collision clipping sideways

PostPosted: Fri Nov 03, 2017 6:58 am
by tall70
NEVER MIND...wheel collision is normal, all original wheels behave same like mine, they all do like on my pictures above...i've seen some R* OFFroad vehicles having better collision around wheels, but after importing them in ZM i see it's done by CHASSIS collision...thank you

you can remove this whole topic to clean up if you wish

Re: wheel collision clipping sideways

PostPosted: Fri Nov 03, 2017 12:30 pm
by Oleg
so is this problem relates to import/export? meaning, importing a good offroad vehicle and exporting it will cause wheel collision to become bad in game?

Re: wheel collision clipping sideways

PostPosted: Fri Nov 03, 2017 1:10 pm
by tall70
No, it's fine... every original " never edited" vehicle does it like on pictures above, first when I seen it on mine it looked odd it seem to be wrong as you see on pictures, but when I checked it with original ones, I found out it's normal. When I checked it first in game I used Mesa 3, it's like a Jeep off-road wheels, that's what confused me, it never clipped in wheels there, because it has chassis Collision around Wheels, I'm sure all those other exposed Wheels cars have it too... thank you for the response but I believe you can remove this topic, unless you have another question

Re: wheel collision clipping sideways

PostPosted: Mon Nov 13, 2017 4:22 am
by tall70
I just encountered similar crash as i described on end of 1st post...I opened save made one move and tried to undo that one move which crashed ZM. I made short video, it's in RAR.

Also i had again had same issue where export from ZM causes bug which makes vehicle float without control, if it's car it usually has no wheels. When i simply open same save in ZM, do NO change, just re-export same thing, it gets fixed. I included both vehicle files, ones which are broken and those after re-export are in folder, if you want to compare. This issue happened to me before with pretty much all mods.

It's no problem to me, i just thought you want to know these things

Re: wheel collision clipping sideways

PostPosted: Fri Nov 17, 2017 2:18 pm
by Oleg
can you send me the .z3d file from the video?

Edit: the "floating" .yft file has bad "E" value set on "gear_f" object. re-exported version has E: {0.000001, 0.000001, 0.000001, 0.000001}
Do you open the .z3d file and just export again? or make an import/re-export to fix it?

Re: wheel collision clipping sideways

PostPosted: Fri Nov 17, 2017 3:21 pm
by tall70
I open a z3D, do no changes and just re-export soon as I open it...i'll send z3d, but it's exactly the same for both

Re: wheel collision clipping sideways

PostPosted: Sat Nov 18, 2017 1:11 am
by Oleg
I've actually asked for .z3d from the video - the .z3d that crashes ZM on dismiss of one compound object.

Re: wheel collision clipping sideways

PostPosted: Sun Nov 19, 2017 6:28 am
by tall70
Every z3d does it for me, undo of very first action will crash it. Even import of YFTs, which that is the first action when it's imported, undo after import will also do same...If you still want me upload my z3d, i'll do it