Light texture not lighting up, invisible mesh behind glass

GTA:V Modding with ZModeler3 discussion.

Moderator: madga182

Light texture not lighting up, invisible mesh behind glass

Postby Algonquin_Hood » Wed Sep 20, 2017 10:22 am

I'm making a car mod where I revamped the taillights. As I tried it ingame, the taillight, brakelight and indicators were not emitting when they should, and indicators weren't even visible because of the glass I've put infront of it. The shaders are correct lightemissive and glasswindows straight from the game, didn't change anything about that.
Thanks in advance
Algonquin_Hood
 
Posts: 30
Joined: Wed Dec 24, 2014 8:04 am

Re: Light texture not lighting up, invisible mesh behind gla

Postby TomcattersVF31 » Wed Sep 20, 2017 10:53 am

First of all I'd make sure that your glass material comes AFTER the light materials in the material hierarchy...
TomcattersVF31
 
Posts: 75
Joined: Fri May 18, 2012 10:13 pm

Re: Light texture not lighting up, invisible mesh behind gla

Postby Algonquin_Hood » Wed Sep 20, 2017 11:55 am

The glass texture was way below the light texture in the materials hierarchy, but I decided to include a transparency square on the light texture itself, so now glass and light use the same one texture.
Algonquin_Hood
 
Posts: 30
Joined: Wed Dec 24, 2014 8:04 am

Re: Light texture not lighting up, invisible mesh behind gla

Postby TomcattersVF31 » Tue Sep 26, 2017 10:57 am

hm, in cases like this I duplicate the material and assign the lower one to the glass... But don't know if that helps in your case.
TomcattersVF31
 
Posts: 75
Joined: Fri May 18, 2012 10:13 pm


Return to Grand Theft Auto V

Who is online

Users browsing this forum: No registered users and 4 guests