Page 1 of 1

Scale object in game view

PostPosted: Fri Aug 04, 2017 2:19 am
by onezolver
When i have changed to big any object scale in ZM, in game screen showing just old size, and make incorrect cut view( obj disappears) cause camera thinking it is out of screen. How i could make big scale with correct view in game?

Re: Scale object in game view

PostPosted: Sun Aug 06, 2017 5:28 am
by Oleg
you should not resize by changing scale in properties of an object; use Modify\Scale tool (click on an object, a flyout window appears -> specify: All axes; then set scaling value with 1000% = 10x scale).

Re: Scale object in game view

PostPosted: Mon Aug 07, 2017 9:50 am
by onezolver
Oleg wrote:you should not resize by changing scale in properties of an object; use Modify\Scale tool (click on an object, a flyout window appears -> specify: All axes; then set scaling value with 1000% = 10x scale).


Got it. So, Oleg, i have read topic [Guide] GTA V: Scene hierarchy, compound objects, geometries.. is those rules correct for ydr files too? Next topic saying "Currently, only vehicle-specific shaders were ported into ZModeler, so the import/export filter as a build-in configuration code for a small subset of available shaders." is that means YDR shaders have to be the same, i cant change it for another from list of ZM gta 5 ones ?

Re: Scale object in game view

PostPosted: Mon Aug 07, 2017 11:38 pm
by Oleg
in most of cases by importing a .ydr model you will get a properly-configured shaders for ydr files. In rare cases you might face an error/warning that particular shader configuration is not available in zmodeler (you will be unable to export such a shader). Some recently-added shaders might be missing in configuration script (the fly-out menu you pick shaders from by clicking on a button with "gears" in top-right corner of materials browser).

Concerning the guide thread, it's quite similar for ydr files. the only difference is you export just one object (instead of "model_hi" and "model"). Also, on export "Skeletal" option should be toggled off for most of ydr files (it might be needed for weapon models, I can't remind correct export options for weapons currently).