Page 1 of 1

Headlights SCS SCANIA 2016

PostPosted: Wed Nov 22, 2017 11:46 pm
by Harald-RS
Hello Oleg,

i have a Problem with the Headlights from the SCS SCANIA 2016.

As soon as I the floodlights after him import again would like to export.

If the indicators and day driving lights do not function any more.

I am real in despair.

I wanted to sit down for the indicators still Flares purely with it the indicators more hard shine the same one is valid for the day driving light.

I hope you can help.

Re: Headlights SCS SCANIA 2016

PostPosted: Fri Mar 02, 2018 1:37 am
by Steinmetz Omi
Yes , i can confirm that, see you pictures.

Image
Image

Import with Zmodeler3 64bit Version 3.2.0 (1179)

Re: Headlights SCS SCANIA 2016

PostPosted: Fri Apr 06, 2018 10:03 am
by Steinmetz Omi
Hello Oleg !
The Bug isn`t solved , what is the problem ?

Re: Headlights SCS SCANIA 2016

PostPosted: Fri Apr 06, 2018 10:29 am
by Oleg
can you specify location of files you import, and post a screenshot from in-game: an original model (where it works fine) and after model have been import/exported.

also, have you tried to put original contents of associated .MAT file into a mod to find out whether this is related to material file or to geometry model?

Re: Headlights SCS SCANIA 2016

PostPosted: Sat Apr 14, 2018 11:41 pm
by Harald-RS
Hello Oleg,

I used the original Mats,

the only one where there had been a new mat was for the glass, since I tinted them in yellow or blue and tinted black. Wanted to do.

z_mod3_uv_mapping_chanale_2 _wrong_after_import.JPG
The UV 2 : was destroyed after import.
z_mod3_uv_mapping_chanale_1 _correct_after_import.JPG
The UV 1: was correct

Re: Headlights SCS SCANIA 2016

PostPosted: Sun Apr 15, 2018 12:51 am
by Oleg
I've checked the file and it seems to use UV#1 on both DETAIL and DETAIL2 (MASK?) slots. The contents of UV#2 looks like trash and unused in game. Just switch material's DETAIL2 slot to "Manual UV#1" on "lamp.add.env" material before export.

Note, this "UV channel config" is suppressed by geometry definition inside a model file, so it can not be configured properly when importing a model (different geometry fragments can give their own channel usage on the same material), so materials are always created with default channels assignment. This issue is identical to "truckpaint" material where you have to specify correct UV channel usage on DETAIL2 slot to get model exported properly and paint-ready.