ui_shadow

SCS Software ATS and ETS2 editing using ZModeler3 filter. Models, Materials, Animation.

Moderators: Oleg, _RicH_

ui_shadow

Postby Lambolist » Wed Jun 07, 2017 1:33 am

Hey there,

I have a problem with the ui_shadow on my truck. In the truckstore I can see the ui_shadow. But if I drive the truck there is no ui_shadow. I tried it to move the shadow up. Than in the store it was in the middle of the truck but on the road it isn't there. I also tried to move the wheel flares down but the same problem.

Lambolist
User avatar
Lambolist
 
Posts: 4
Joined: Sat Dec 26, 2015 4:37 am

Re: ui_shadow

Postby Oleg » Thu Jun 08, 2017 1:56 am

not sure on ui shadow, it might have some specific settings needed, I used to test original game models only. flares issue might have something related to "wheel was moved but appears in old position in game" issue: when you change placement of wheel dummy in truck.pmd/.pmg files, the wheel appears in old position in game unless you update truck_lod model too.
User avatar
Oleg
Site Admin
 
Posts: 7774
Joined: Fri Feb 06, 2004 3:54 am

Re: ui_shadow

Postby Lambolist » Thu Jun 08, 2017 9:51 am

I don't use a lod for my trucks. But the strange is that the ui_shadow works in the store or in the truckdealer but not on the road.
User avatar
Lambolist
 
Posts: 4
Joined: Sat Dec 26, 2015 4:37 am

Re: ui_shadow

Postby Oleg » Fri Jun 09, 2017 1:20 am

is your mod a completely new addon truck or a modification of existing truck? I suspect fake shadow is somehow configured outside of the model. I remind older versions of the game used dummy nodes / locators to specify corners of ui shadow and were not using actual shadow object; newer versions has some polygons mapped onto material with "fakeshadow" adaptation on it (don't be mislead to "shadowonly" adaptation used on polygons to render drop-shadow of solid objects).
User avatar
Oleg
Site Admin
 
Posts: 7774
Joined: Fri Feb 06, 2004 3:54 am

Re: ui_shadow

Postby Lambolist » Fri Jun 09, 2017 1:42 am

My mod is a complete standalone truck so no base def. And the shadowonly works perfektly but not the ui_shadow under the truck.
User avatar
Lambolist
 
Posts: 4
Joined: Sat Dec 26, 2015 4:37 am

Re: ui_shadow

Postby Oleg » Fri Jun 09, 2017 2:04 am

you should check defs for original truck, I guess you've missed something. also, try flipping ui_shadow object inside out, it might be related to the issue.
User avatar
Oleg
Site Admin
 
Posts: 7774
Joined: Fri Feb 06, 2004 3:54 am

Re: ui_shadow

Postby Lambolist » Fri Jun 09, 2017 2:46 am

I have checked the defs there is every thing like in the original and the strange is that the ui_shadow works in the truckdealer but not on the road.
User avatar
Lambolist
 
Posts: 4
Joined: Sat Dec 26, 2015 4:37 am


Return to ATS and ETS2 by SCS Software

Who is online

Users browsing this forum: Harald-RS and 2 guests