Trailer bug

SCS Software ATS and ETS2 editing using ZModeler3 filter. Models, Materials, Animation.

Moderators: Oleg, _RicH_

Trailer bug

Postby siebel3d » Sat Apr 29, 2017 1:49 pm

Hi

I started to make this like another normal mod, but when I exported the first time, the game crashed, without any errors in game.log.
Then I tried to import the same trailer, and this happened. It's like I attached all the pieces together, turning into only one piece.

Image

Only when I mark "Merge Models" this don't happen.

The only error in Zmodeler when I import the pmd is "This model requires skeleton and bones weighting but was loaded sliced by bones ID."

How can I solve it?


==
Printscreen: http://i.imgur.com/RUBqSaW.png?1
ALWAYS WITH AN OLD TRUCK
Facebook.com/siebel3d
User avatar
siebel3d
 
Posts: 6
Joined: Wed Dec 21, 2016 6:52 am
Location: Videira - SC, Brazil

Re: Trailer bug

Postby Oleg » Mon May 01, 2017 4:16 am

common issue with geometry object exceeding 64K vertices on it. Load your model with no models merging, then use Modify\Attach tool to merge objects inside ZModeler. Once you approach the limit on an object, start attaching to a different object, so you have multiple geometries. It might look like this:
Code: Select all
truck
   Cab_a
      Mesh01
      Mesh02
      Mesh03


or

truck
   Cab_a_1
      Mesh01
   Cab_a_2
      Mesh02
   Cab_a_3
      Mesh03

both hierarchy variants are Ok, but the second one will give correct result on export (not sure on the first one - it might be ok too, I can't remind whether limits are checked and respected or not)
User avatar
Oleg
Site Admin
 
Posts: 7392
Joined: Fri Feb 06, 2004 3:54 am

Re: Trailer bug

Postby siebel3d » Mon May 01, 2017 4:56 am

Well, this part it's fixed. But still crashing the game. And I assume the error is in pmg/pmd file, because I replaced the defs for the original defs from the game, and still not working.

There's no error about that in game.log
ALWAYS WITH AN OLD TRUCK
Facebook.com/siebel3d
User avatar
siebel3d
 
Posts: 6
Joined: Wed Dec 21, 2016 6:52 am
Location: Videira - SC, Brazil

Re: Trailer bug

Postby Oleg » Mon May 01, 2017 5:26 am

reduce parts/materials and make several test exports. the problem might be related to just one material or just one object.. you can probably locate it by a series of test exports.
User avatar
Oleg
Site Admin
 
Posts: 7392
Joined: Fri Feb 06, 2004 3:54 am

Re: Trailer bug

Postby siebel3d » Mon May 01, 2017 5:56 am

Well, I exported a lot of times, taking of some pieces and etc. it only worked when I leave only the dummies and the collision.
Image

What could be the problem with the 3D pieces?
ALWAYS WITH AN OLD TRUCK
Facebook.com/siebel3d
User avatar
siebel3d
 
Posts: 6
Joined: Wed Dec 21, 2016 6:52 am
Location: Videira - SC, Brazil


Return to ATS and ETS2 by SCS Software

Who is online

Users browsing this forum: No registered users and 1 guest