Having issues with opening z3d files

SCS Software ATS and ETS2 editing using ZModeler3 filter. Models, Materials, Animation.

Moderators: Oleg, _RicH_

Having issues with opening z3d files

Postby mac101968 » Mon Jan 09, 2017 11:24 pm

I worked on a ats model and after my work i always save as a Zmodeler3 z3d file...which I always do when working on a ats model... export seems to go fine but, when i either clear zmod3 or close it...and try to open the file again it crashes zmod3 ?...sometimes i can open the folder the z3d file is in and double tick on the file and zmod3 will open it...sometimes not..when i open zmod3 from the exc. then try to open the z3d file again it crashes zmod3...and that happens sometimes and not others ...more often than not with either method of trying to open saved zmodeler3 z3d files...everything was fine until the last few days with the recent updates...i am doing nothing different than i have for the past 6 months i have no idea how to solve this issue?...legit paid copy...1 year subscription...Ver 3.1.4 build 1141.. A fix or help would be greatly appreciated.
mac101968
 
Posts: 3
Joined: Fri Aug 19, 2016 7:47 pm

Re: Having issues with opening z3d files

Postby Oleg » Tue Jan 10, 2017 12:52 am

does this happen on a specific .z3d file? you can send me the file so I could take a look.
Also, does this depend on file size (e.g. happens on very big files and never happens on small files) ?
User avatar
Oleg
Site Admin
 
Posts: 7576
Joined: Fri Feb 06, 2004 3:54 am

Re: Having issues with opening z3d files

Postby mac101968 » Tue Jan 10, 2017 7:47 am

It happens with any ats truck file a save as a z3d file...also file size dosent seem to matter. I will try to send the file after work ...but it does happen with any ats model i try saving as a z3d file
mac101968
 
Posts: 3
Joined: Fri Aug 19, 2016 7:47 pm

Re: Having issues with opening z3d files

Postby mac101968 » Tue Jan 10, 2017 12:09 pm

upon gettitng home today ...I opened zmod3...then i tried to open a truck i saved as a zmodelr3 z3d file last nite...i did NOTHING to it last nite just imported and saved as z3d...today the first time i tried to open it in zmod3 it crashed zmod3...So I tried again...that time it worked fine...So i Ticked new and cleared the scene and tried to open again...Agian it opened...i have done that 3 times now with no issues...So then i closed zmodeler3 ...then opened it again fresh and tried to open the same z3d file and it crashes zmod3 :shock: ...so I opened zmod3 again and tried again and this time it opens the z3d file fine again :?
I have uploaded the truck i am having issues with to my dropbox folder...
https://www.dropbox.com/s/mm0y3dult49m0 ... 9.zip?dl=0
mac101968
 
Posts: 3
Joined: Fri Aug 19, 2016 7:47 pm

Re: Having issues with opening z3d files

Postby Oleg » Tue Jan 10, 2017 2:37 pm

Seems to be a problem with ATI2-compressed textures on DirectX 9 core. I've added a walk-around solution, it should be fine now. Get an update, your files should open/save/new with no appcrash.
User avatar
Oleg
Site Admin
 
Posts: 7576
Joined: Fri Feb 06, 2004 3:54 am


Return to ATS and ETS2 by SCS Software

Who is online

Users browsing this forum: No registered users and 2 guests