Page 1 of 1

uv mapping slow and lag in uv mapper

PostPosted: Fri Aug 25, 2017 11:18 am
by Toma
when i try to make uv on something more highpoly the zmod is soo slow and when i try to move something in uv mapper it's feels like i have 1 fps
pc spec
Image

it's really annoying in zmodeler2 this wasnt a problem

Re: uv mapping slow and lag in uv mapper

PostPosted: Sat Aug 26, 2017 2:25 am
by Toma
#UPDATE now even when i go to vertex mode the zmod it's freezing

Re: uv mapping slow and lag in uv mapper

PostPosted: Sun Aug 27, 2017 3:52 am
by Oleg
running the latest version with the latest updates being installed?

Edit: make sure your Settings -> Rendering Device -> "Cache" option is set to "Automatic", as it might have arrived with "Always" option being set in downloaded version.

Re: uv mapping slow and lag in uv mapper

PostPosted: Sun Aug 27, 2017 6:04 am
by Toma
yes i have the last update
Image
i tried with antialaising at 2 4 8 and disable but always is the same
im sad because i made the truck in zmodeler2 as 3d and there i didnt had lag at uv or anything else

Re: uv mapping slow and lag in uv mapper

PostPosted: Sun Aug 27, 2017 6:25 am
by Oleg
zmod3 has way slower uv mapper as it processes and inspects much more data while editing uv. if you had zmod3 doing it better earlier, I'll inspect this case what could get worse in latest versions.

Re: uv mapping slow and lag in uv mapper

PostPosted: Sun Aug 27, 2017 6:37 am
by Toma
ok thanks i talked with some other modders and they said it could be because the program is not on 64 bit it's any chance to be true ?

Re: uv mapping slow and lag in uv mapper

PostPosted: Sun Aug 27, 2017 7:16 am
by Oleg
no. it's mostly related to application is single-threaded (runs on just one core of your multi-core CPU).

Re: uv mapping slow and lag in uv mapper

PostPosted: Sun Aug 27, 2017 9:20 am
by Toma
i understand now but there is no chance to make the zmodeler multicore ? a lot of modders are sad because of the uv map or when we use highpoly trucks ... and still we pay money for the program every month

Re: uv mapping slow and lag in uv mapper

PostPosted: Mon Aug 28, 2017 4:38 am
by Oleg
I afraid it's barely possible as it requires a different core design laid in a basement of entire application. I do make multi-core computations where it's safe and possible ( uv render, vertices prelight computation and some other tasks that can be performed with an isolated data). running uv-mapping or geometry update on multi core requires additional (synchronization, blocking and waiting) logic in just every aspect of zmodeler from drawing viewports/objects to updating their geometry or reading properties on selected elements. literally, it's an absolutely different core design for an application. :(

Re: uv mapping slow and lag in uv mapper

PostPosted: Wed Sep 20, 2017 5:40 am
by Chasez
I'm having the same terrible lag in the new version aswell. After a while of long waiting from freezes Zmod crashes which drives me crazy now.

Re: uv mapping slow and lag in uv mapper

PostPosted: Wed Sep 20, 2017 5:53 am
by Oleg
this issue will be under inspection in upcoming days. there is another task I need to complete first, but I have significantly more time for zmod compared to past months, so it wont take real much time I suppose.