[GTASA] Windscreen problem

GTA San Andreas and GTA Vice City discussion.

Moderators: Oleg, _RicH_

[GTASA] Windscreen problem

Postby R3W1ND » Sat Apr 09, 2016 9:14 am

Hello. I have a problem with windscreen transparency.
This is the viewport in ZModeler 2.1.1

Image

As you can see..there are no problems here. The car's windscreen looks fine. As in GGMM

Image

But..ingame :

Image



I dont know why..the windscreen material and the rest of windows are same. But this only happens to windscreen part.
R3W1ND
 
Posts: 17
Joined: Fri Jan 01, 2016 8:33 am

Re: [GTASA] Windscreen problem

Postby Oleg » Sat Apr 09, 2016 9:18 am

set 2 uv channels on windscreen object; properties->mesh->vertices->format->uv channels = 2; apply.
User avatar
Oleg
Site Admin
 
Posts: 7828
Joined: Fri Feb 06, 2004 3:54 am

Re: [GTASA] Windscreen problem

Postby R3W1ND » Sat Apr 09, 2016 10:34 pm

Problem solved ! Thanks !
Second question :

The license plates is correctly assigned to carplate.bmp and carpback.bmp in material editor. But why it wont work ingame ? Its only plain white ingame.
Last edited by R3W1ND on Sat Apr 09, 2016 10:34 pm, edited 1 time in total.
R3W1ND
 
Posts: 17
Joined: Fri Jan 01, 2016 8:33 am

Re: [GTASA] Windscreen problem

Postby Oleg » Sat Apr 09, 2016 11:02 pm

load original material. may be something specific should be set too. alternatively, load original vehicle and use original pre-configured material on your model. or even more, use original polygons with original material on your model.
User avatar
Oleg
Site Admin
 
Posts: 7828
Joined: Fri Feb 06, 2004 3:54 am

Re: [GTASA] Windscreen problem

Postby R3W1ND » Sun Apr 10, 2016 12:32 am

You mean detach original SA model and leave only license plate part then attach to my car ? Ok I'll try it.
R3W1ND
 
Posts: 17
Joined: Fri Jan 01, 2016 8:33 am

Re: [GTASA] Windscreen problem

Postby R3W1ND » Sun Apr 10, 2016 2:43 am

Solved !
Question three.. How to export only collision file from dff ?
R3W1ND
 
Posts: 17
Joined: Fri Jan 01, 2016 8:33 am

Re: [GTASA] Windscreen problem

Postby Oleg » Sun Apr 10, 2016 6:34 am

export entire model into some folder and delete the rest, just keep .col file.
User avatar
Oleg
Site Admin
 
Posts: 7828
Joined: Fri Feb 06, 2004 3:54 am

Re: [GTASA] Windscreen problem

Postby R3W1ND » Sun Apr 10, 2016 7:53 am

Tried once but fail. cannot export it with .col extension format
R3W1ND
 
Posts: 17
Joined: Fri Jan 01, 2016 8:33 am

Re: [GTASA] Windscreen problem

Postby Automan » Sun Apr 10, 2016 10:35 pm

:shock: Collision can be saved alone:
https://s30.postimg.org/459h0vdm9/collisiononly.jpg
even if an error is detected.
However, a .dff with only a Collision is useless! :roll: :D
User avatar
Automan
Beginner
 
Posts: 113
Joined: Tue Mar 06, 2007 1:27 pm
Location: Italy

Re: [GTASA] Windscreen problem

Postby R3W1ND » Wed Apr 13, 2016 8:59 am

Okay thanks Oleg and Automan ! The .col problem is solved without any .col editor :D


Next question :

I want to make a badge like this. Nearly all GTA IV/V vehicles use this
Image

But I can't find correct alpha settings for that. This is mine.
Image

I'm using BMP textures. What's the problem ?
R3W1ND
 
Posts: 17
Joined: Fri Jan 01, 2016 8:33 am

Re: [GTASA] Windscreen problem

Postby Oleg » Wed Apr 13, 2016 10:01 am

BMP textures in most of cases have no alpha channel and can't be used for transparent badges. try PNG or DDS textures.
User avatar
Oleg
Site Admin
 
Posts: 7828
Joined: Fri Feb 06, 2004 3:54 am

Re: [GTASA] Windscreen problem

Postby R3W1ND » Wed Apr 13, 2016 1:58 pm

Thanks again, Oleg. It works with PNG.

But seems like alpha-based textures like scratch is blinking whenever I turn-on ENB. When ENB is off, textures are normal.
R3W1ND
 
Posts: 17
Joined: Fri Jan 01, 2016 8:33 am

Re: [GTASA] Windscreen problem

Postby Automan » Wed Apr 13, 2016 11:59 pm

ENB series by Boris Vorontsov?... :)
In this case, the material has [spec] and/or [env], and if so, with what values? :)
User avatar
Automan
Beginner
 
Posts: 113
Joined: Tue Mar 06, 2007 1:27 pm
Location: Italy

Re: [GTASA] Windscreen problem

Postby R3W1ND » Thu Apr 14, 2016 4:33 am

The "blinking" textures only happens with scratch and vehicleshatter. This does not happen with IV/V badges. I'm only using [spec]
R3W1ND
 
Posts: 17
Joined: Fri Jan 01, 2016 8:33 am

Re: [GTASA] Windscreen problem

Postby R3W1ND » Mon Apr 25, 2016 4:57 am

Oleg, I need your explain about this :

Image


The "scratch" and "shatter" texture on doors looks like pixelated which is bad. The other parts were fine. Why this is happen ?
R3W1ND
 
Posts: 17
Joined: Fri Jan 01, 2016 8:33 am

Re: [GTASA] Windscreen problem

Postby Automan » Tue Apr 26, 2016 11:19 pm

It's a original car?... :)
User avatar
Automan
Beginner
 
Posts: 113
Joined: Tue Mar 06, 2007 1:27 pm
Location: Italy

Re: [GTASA] Windscreen problem

Postby R3W1ND » Sun May 01, 2016 2:52 am

@Automan it's a modified Bravura :D
R3W1ND
 
Posts: 17
Joined: Fri Jan 01, 2016 8:33 am

Re: [GTASA] Windscreen problem

Postby Automan » Mon May 02, 2016 12:09 am

Well, you must to move a little the scratch and shatter surfaces from the paint and glass surface.
Otherwise because a shaining effect, and Jack Nicholson asks you the copyrights! :)
User avatar
Automan
Beginner
 
Posts: 113
Joined: Tue Mar 06, 2007 1:27 pm
Location: Italy

Re: [GTASA] Windscreen problem

Postby R3W1ND » Wed May 18, 2016 7:38 am

Image

Hello..how to fix this ? The camera is located too close to the car. How to move it in Zmodeler ?
R3W1ND
 
Posts: 17
Joined: Fri Jan 01, 2016 8:33 am

Re: [GTASA] Windscreen problem

Postby Oleg » Wed May 18, 2016 9:57 am

you can't move it in ZModeler. You can create a dummy part and move it to the back of the car, a bit away of the trunk. the overal "dimensions" of the car will get bigger and camera will not come that close to the vehicle.

just a guess, not sure whether this will work or not.
User avatar
Oleg
Site Admin
 
Posts: 7828
Joined: Fri Feb 06, 2004 3:54 am

Re: [GTASA] Windscreen problem

Postby Automan » Wed May 18, 2016 11:59 pm

There are three viewing positions in the GTA-SA. I think this is enough ...
However, as Oleg said, the camera location depends encumbrance of the model, including chassis_vlo.
Create a cube with invisible texture to attach to the chassis (alpha texture all black):
Image
User avatar
Automan
Beginner
 
Posts: 113
Joined: Tue Mar 06, 2007 1:27 pm
Location: Italy

Re: [GTASA] Windscreen problem

Postby R3W1ND » Fri May 20, 2016 3:51 am

Seems like I've discovered my own rule before I saw your reply, Automan. Just move the dff file (eg: euros.dff) to the front if you want the camera goes farther.
R3W1ND
 
Posts: 17
Joined: Fri Jan 01, 2016 8:33 am

Re: [GTASA] Windscreen problem

Postby Automan » Fri May 20, 2016 7:30 am

R3W1ND wrote:Seems like I've discovered my own rule before I saw your reply, Automan. Just move the dff file (eg: euros.dff) to the front if you want the camera goes farther.

No, not a good idea because it shifts the center of gravity (the collision spheres as well as the strength of the vehicle are also responsible for its mass), and you can not always make up for it in handling.cfg file. :)
Image
User avatar
Automan
Beginner
 
Posts: 113
Joined: Tue Mar 06, 2007 1:27 pm
Location: Italy


Return to Grand Theft Auto

Who is online

Users browsing this forum: No registered users and 1 guest