Uv maps keep getting stuck

Discuss ZModeler 1 series issues here, ask for help and help others to become advanced users

Moderators: Oleg, _RicH_

AMANGG
Posts: 3
Joined: Thu Nov 10, 2022 12:41 am

Uv maps keep getting stuck

Post by AMANGG »

:cry: I keep having this problem where After i uv unwrap a car and sometime passes, i cant select the uvs again, i have tried uv unwarping it again and again but it works for a short duration before the uvs stop getting selected no mater what i do, they wont even show up when i try to uv render, also I have tried it on both old mapping and new mapping, new mapping doesn't work old mapping keeps stretching the uv, please help
User avatar
Oleg
Site Admin
Posts: 12511
Joined: Fri Feb 06, 2004 3:54 am
Contact:

Re: Uv maps keep getting stuck

Post by Oleg »

Uv data in UV Mapper can get disabled at some point when the actual object topology is changed (so the chart in UV Mapper does not reflect the actual state of geometry object). This is the case, in particular, if you create seams on a model while editing UV. In general, you should not edit mesh topology in any way while editing UV, so create seams, detaching/attaching before you start UV editing process.

You can clear UV mapper by closing all UV mapper windows and starting again with Edit UV tool to generate correct UV charts again.
AMANGG
Posts: 3
Joined: Thu Nov 10, 2022 12:41 am

Re: Uv maps keep getting stuck

Post by AMANGG »

Thanks for responding but I didn't edit the mesh in any way, for a test I even opened a new project uv unwrapped one side of a car and once i unwrap the other side, the uv is stuck, can't even select it again, here are the images


Image

Image
User avatar
Oleg
Site Admin
Posts: 12511
Joined: Fri Feb 06, 2004 3:54 am
Contact:

Re: Uv maps keep getting stuck

Post by Oleg »

I don't see what exactly is wrong given these two screenshots. On both of them the object inside UV editor looks editable (not dimmed/disabled). Are you unable to edit it? can you select it, hover or anything? Note, if you have automatic selection mode (Auto button in the bottom of ZModeler window), it could automatically trigger "Selected" mode button on the left on/off for scene selection, and might not trigger it properly for uv-mapper window. For example, if you have objects selected in scene, the "Selected" button toggles on, you pick the "Move" tool and try to move an object in UVMapper window (that is not selected) by hovering it and... nothing moves, because ZModeler expects "Selected" object to be moved and nothing is selected in UV Mapper.

That's the only thing I could think of to the moment.
Once you get the stuck UV object in UV Mapper, save as a separate .z3d file and send it to me via private message, so I could take a look - may be something else is wrong.
AMANGG
Posts: 3
Joined: Thu Nov 10, 2022 12:41 am

Re: Uv maps keep getting stuck

Post by AMANGG »

thanks for responding again, i have tried it with both auto select on and off and also by turning off selected manually, the problem is i can't edit it or the uv wont change when I hover over it , here are the project files

link; https://files.fm/u/n3k3tevdh
Post Reply