Search found 34 matches

by pnwparksfan
Mon Jan 22, 2024 9:24 pm
Forum: Grand Theft Auto V
Topic: GTA5: Animation files (YCD)
Replies: 10
Views: 12655

Re: GTA5: Animation files (YCD)

If I get it right, you can create a "lasting" events on [tags] track by setting an event number on an event. A positive number to indicate a start of the event and the matching negative number to set the end of the event. Literally: "Lasting tag is determined by availability of closi...
by pnwparksfan
Sun Jan 21, 2024 4:00 pm
Forum: Grand Theft Auto V
Topic: GTA5: Animation files (YCD)
Replies: 10
Views: 12655

Re: GTA5: Animation files (YCD)

I have been doing some research to figure out how to add custom animation events to be used with the HAS_ANIM_EVENT_FIRED native in scripts. Per the native documentation, it says: Some events are instantaneous (so this will only return true once). Others may have duration, which means that this func...
by pnwparksfan
Wed Dec 06, 2023 7:52 pm
Forum: ZModeler3 Account and Licenses
Topic: License expired early
Replies: 1
Views: 1012

License expired early

I activated a 90 day license on September 9, which should be active through December 8. However today zmodeler3 is asking me to revalidate my license, and my profile shows the license is expired with 0 days left. I did not deactivate/transfer the license at any point. Why was it terminated two days ...
by pnwparksfan
Tue Jan 03, 2023 12:50 am
Forum: ZModeler3 General discussion
Topic: Animation tool resets position of objects when rearranging node hierarchy
Replies: 3
Views: 2632

Re: Animation tool resets position of objects when rearranging node hierarchy

It might be related to animation properties. It has an option "Relative to bind" and "World tracks". The first one makes animation tracks to record relative changes (relative to bind position) when it's on and absolute position/rotation when it's off. The second option is probab...
by pnwparksfan
Mon Jan 02, 2023 10:23 pm
Forum: ZModeler3 General discussion
Topic: Animation tool resets position of objects when rearranging node hierarchy
Replies: 3
Views: 2632

Animation tool resets position of objects when rearranging node hierarchy

When creating an animation, even if it only affects animation , moving any animated item in the hierarchy causes its position to be reset to have the same offset relative to the new parent dummy as the it had relative to the old parent dummy, instead of updating the position relative to the new pare...
by pnwparksfan
Mon Jan 02, 2023 10:05 pm
Forum: ZModeler3 General discussion
Topic: Rotation affects LODs inconsistently, especially with Undo
Replies: 3
Views: 2307

Re: Rotation affects LODs inconsistently, especially with Undo

It looks like the issue is with update after undo/redo on compound objects. The object is not messed actually when you undo, just switch to vertices mode and back to object mode, you will see everything is actually fine. The compound object seems not to update properly its build-in nodes when undo ...
by pnwparksfan
Sun Jan 01, 2023 3:17 pm
Forum: ZModeler3 General discussion
Topic: Rotation affects LODs inconsistently, especially with Undo
Replies: 3
Views: 2307

Rotation affects LODs inconsistently, especially with Undo

If you use the rotate tool on object level with an object with LODs, it sometimes affects only the selected LOD, and sometimes affects other LODs. When you click undo, it always only applies the undo on the currently visible LOD. As a result, it is very easy to mess up a model when using the rotate ...
by pnwparksfan
Tue Mar 01, 2022 10:55 pm
Forum: Grand Theft Auto V
Topic: Can you make a boat with doors?
Replies: 1
Views: 878

Re: Can you make a boat with doors?

Boats do not support doors
by pnwparksfan
Sun Oct 25, 2020 8:24 pm
Forum: Grand Theft Auto V
Topic: Missing cloth shaders
Replies: 0
Views: 1371

Missing cloth shaders

None of the cloth shaders appear under the shader selection menu in the material editor, they can only be used by importing manually.

Furthermore, props with shader cloth_normal_spec_tnt cannot be exported. This shader is available on props like prop_skid_tent_01.yft.
by pnwparksfan
Sun Oct 25, 2020 8:10 pm
Forum: ZModeler3 General discussion
Topic: User-defined properties on closed COL groups not saving
Replies: 1
Views: 2448

User-defined properties on closed COL groups not saving

ZModeler3 has an issue where user-defined properties defined on a closed COL group are lost when saving and reopening the z3d file. To quickly reproduce this issue, import the prop prop_parasol_02 , then view the user-defined properties on the node Paral_02_top [COL] : just-after-import.PNG Save the...
by pnwparksfan
Thu Sep 10, 2020 7:54 pm
Forum: Tech support (forum, account, licenses)
Topic: Can't rotate viewport using Alt+Middle Click
Replies: 2
Views: 2000

Re: Can't rotate viewport using Alt+Middle Click

Silly me. Had been a while since I used zmodeler and I had been using other 3D software where you rotate by clicking the scroll button. Thanks for the reminder.
by pnwparksfan
Thu Aug 27, 2020 8:09 pm
Forum: Tech support (forum, account, licenses)
Topic: Can't rotate viewport using Alt+Middle Click
Replies: 2
Views: 2000

Can't rotate viewport using Alt+Middle Click

I haven't opened zmodeler in a while, and now I can no longer rotate 3D or Perspective viewports by holding Alt + Middle Click. My middle click works (I can still pan) and my alt key works (I can press Ctrl+Alt+Del), but zmod won't recognize them to rotate.
by pnwparksfan
Mon Apr 20, 2020 9:24 pm
Forum: Grand Theft Auto V
Topic: "Show" not working on hidden vertices/polygons
Replies: 3
Views: 1699

Re: "Show" not working on hidden vertices/polygons

This still happens intermittently. How is the "Show" button supposed to work? Could you add a "show all" button for poly/vertex mode which always just shows everything regardless of selection status?
by pnwparksfan
Mon Mar 09, 2020 12:27 pm
Forum: Grand Theft Auto V
Topic: Max Number of Non ELS Sirens
Replies: 5
Views: 2722

Re: Max Number of Non ELS Sirens

The game is hard coded to a limit of 20 sirens.
by pnwparksfan
Mon Mar 09, 2020 12:06 pm
Forum: Grand Theft Auto V
Topic: Report Import/Export bugs here
Replies: 1871
Views: 973641

Re: Report Import/Export bugs here

You should save your work as .z3d file, do not rely on re-importing your models. If you have downloaded some mod from the web, it might happen the file is corrupt and will not get loaded. ZModeler should be able to import original game models and .yft files created by ZModeler with no updates. In p...
by pnwparksfan
Sat Feb 22, 2020 9:08 pm
Forum: Tech support (forum, account, licenses)
Topic: Can't post in general discussion forum
Replies: 5
Views: 3096

Re: Can't post in general discussion forum

Oleg wrote:You should probably log out at forum and log in again.
I have tried logging out and back in, and still cannot post in that forum.
by pnwparksfan
Tue Feb 18, 2020 12:21 am
Forum: Tech support (forum, account, licenses)
Topic: Can't post in general discussion forum
Replies: 5
Views: 3096

Re: Can't post in general discussion forum

Your forum username is not linked to your ZModeler3 web account. Clear all private messages (inbox, outbox, saved, deleted) and bind your forum username with your ZModeler2 account on "Settings" page in web account. There is nothing about binding to forum in the settings page of my web ac...
by pnwparksfan
Mon Feb 17, 2020 10:30 pm
Forum: Tech support (forum, account, licenses)
Topic: Can't post in general discussion forum
Replies: 5
Views: 3096

Can't post in general discussion forum

When I go to the General Discussion forum the "New Topic" button is not there. In every other forum the button is there. Why can't I post to that forum?

It looks like it might be because I am not a member of the ZM3 users group, but I have an active license.
by pnwparksfan
Mon Jan 20, 2020 9:19 pm
Forum: Grand Theft Auto V
Topic: "Show" not working on hidden vertices/polygons
Replies: 3
Views: 1699

"Show" not working on hidden vertices/polygons

I've noticed that sometimes the Show button on the Display tab does not work if I have hidden vertices or polygons. I enter vertex or polygon mode on the part with the hidden polys/vertices, and hitting Show does not do anything, regardless of what is selected.
by pnwparksfan
Fri Nov 23, 2018 12:08 pm
Forum: Grand Theft Auto V
Topic: Report Import/Export bugs here
Replies: 1871
Views: 973641

Re: Report Import/Export bugs here

It appears that importing two models, a _hi.yft model and a regular .yft model, at the same time, with "split to parts" unchecked and "combine with existing models" checked, can result in L0 getting messed up. I'm not exactly sure what is wrong with it, but vertices are in the wr...
by pnwparksfan
Tue Mar 20, 2018 2:50 pm
Forum: Site news and events
Topic: GTA5: Cloth-simulated meshes
Replies: 64
Views: 78213

Re: GTA5: Cloth-simulated meshes

Would it be possible for you to check when exporting cloth objects, and if no vertices have a static point, warn the user? On a couple occasions I've accidentally forgotten to set or accidentally deleted all of the static vertices. Then when I got in game I was of course confused why my cloth disapp...
by pnwparksfan
Mon Mar 19, 2018 5:52 am
Forum: Site news and events
Topic: GTA5: Cloth-simulated meshes
Replies: 64
Views: 78213

Re: GTA5: Cloth-simulated meshes

Oleg wrote:if i'm not mistaken, the first parameter (elasticity?) should be very small value like 0.0005 to prevent excessive stretch.
Even at very low elasticity like 0.0001 it still seems to stretch the same amount.
by pnwparksfan
Sun Mar 18, 2018 7:16 pm
Forum: Site news and events
Topic: GTA5: Cloth-simulated meshes
Replies: 64
Views: 78213

Re: GTA5: Cloth-simulated meshes

Oleg, do you have any idea which parameter (if any) might control how far the cloth can stretch? I've noticed that with very large cloth pieces, they will bend very far, and it seems to bend the same amount regardless of any options which I apply. Perhaps it's related also to the number of polygons?
by pnwparksfan
Thu Mar 15, 2018 1:27 pm
Forum: Site news and events
Topic: GTA5: Cloth-simulated meshes
Replies: 64
Views: 78213

Re: GTA5: Cloth-simulated meshes

Did some more testing recently and made a new mesh that I applied cloth settings to. Discovered that some combinations of the values in User Defined Options on a .cloth node result in the cloth being completely invisible in game. When I import cloth-only props, they only appear about half of the opt...
by pnwparksfan
Mon Mar 12, 2018 11:49 pm
Forum: Site news and events
Topic: GTA5: Cloth-simulated meshes
Replies: 64
Views: 78213

Re: GTA5: Cloth-simulated meshes

I haven't tried making an entirely new cloth-only model yet, only editing existing ones. In testing with the flag props and with vb_28_tape.yft in both cases nothing spawned at all when I just exported it even without changes. I was finally able to get custom cloth working in a prop by using the str...